Plan your meeting

System requirements for the webmeeting application

18 views 17. January 2019 17. January 2019 fgoetz 0

We recommend your use of one of the following browsers:

  • Firefox from Version 52
  • Chrome from Version 61

If one of these browsers and the versions mentioned exists, you can use all the functions of the application. Otherwise, you can manage and control your conference topics via webmeeting.online.

Alternatively you can download our app:

Was that helpful?